SVERWEIS versus INDEX / VERGLEICH

Bookmark and Share

Dieser Blog Beitrag erläutert verschiedene Varianten um Daten zu suchen und auszulesen.

Dabei wird auf fogende beiden Varianten eingegangen:

Variante 1: SVERWEIS()

=SVERWEIS(Suchkriterium;  Suchmatrix; Ergebnisspalte; [exakter Treffer])

Mit SVERWEIS können allerdings nur Daten ausgelesen werden, die sich rechts neben der Suchspalte befinden.

Variante 2: INDEX / VERGEICH

=INDEX(Matrix; VERGLEICH(Suchkriterium; Matrix)

Diese Variante ermöglicht es auch, Daten zu suchen und auszulesen, welche links von der Suchspalte stehen.

 

Nachfolgend sehen Sie verschiedene Verianten, um die Artikelbezeichnung bzw. den Lagerort für eine beliebige Artikelnumer zu suchen.

Beispiel 1 verwendet den Befehl SVERWEIS():

Erfassen Sie dazu folgende Formel: =SVERWEIS(E6;$B$5:$C$20;2;0)

Der Suchbegriff, also die Artikelnummer befindet sich in Zelle E6.

 

Beispiel 2 liest die Artikelbezeichnung mit Hilfe der kombinierten Funktionen INDEX/VERGLEICH aus:

Folgende Funktion ist dazu notwendig, wenn der Suchbegriff (Artikelnummer) in der Zelle E12 steht :
=INDEX(C5:C20;VERGLEICH(E12;B5:B20;0))


Beispiel 3 liest ebenfalls mit Hilfe von INDEX/VERGLEICH den Lagerort aus, also die Spalte links neben den Suchbegriff. Diese Art des Auslesens lässt sich mit SVERWEIS so nicht umsetzen.

Verwenden Sie dazu folgende Formel: =INDEX(A5:A20;VERGLEICH(E18;B5:B20;0)). Der Suchbegriff befindet sich in Zelle E18.

 

>>> Den gesamten Beitrag finden Sie hier auf Excel-Inside.de.


Ein Kommentar

  1. Can i add your feed to my android phone app feedr?